MyAccount Outage
Incident Report for Brown University
Resolved
MyAccount services are stable and validated. This issue has been resolved.
Posted Apr 23, 2024 - 12:37 EDT
Update
MyAccount services appear to be improving. OIT is still working on investigating and identifying the issue.
Posted Apr 23, 2024 - 12:07 EDT
Investigating
Users are currently experiencing problems accessing myaccount.brown.edu. OIT is currently investigating this issue.
Posted Apr 23, 2024 - 11:54 EDT
This incident affected: Information Security and Accounts (MyAccount - myaccount.brown.edu).