Widespread AWS Service Disruption

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:45 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:49 EDT

Update

A widespread AWS service disruption is currently causing degraded performance and intermittent outages across a vast number of applications. Known applications that are currently affected include:

Atlassian Products (Jira, JSM)
Canvas Course Platform
BrownBuys
Brown Contract Management System
Cognos
Digital Signage (Screencloud)
Qualtrics
Panopto
Snowflake
Tableau
Zoom
Posted Oct 20, 2025 - 15:01 EDT

Update

A widespread AWS service disruption is currently causing degraded performance and intermittent outages across a vast number of applications. Known applications that are currently affected include:

Atlassian Products (Jira, JSM)
Canvas Course Platform
Jaggaer
Qualtrics
Snowflake
Posted Oct 20, 2025 - 13:55 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 12:15 EDT

Investigating

A widespread AWS service disruption is currently causing degraded performance and intermittent outages across a vast number of applications. Known applications that are currently affected include:

Atlassian Products (Jira, JSM)
Canvas Course Platform
Qualtrics
Snowflake
Posted Oct 20, 2025 - 12:12 EDT
This incident affected: Other (Other), Teaching and Learning (Canvas Course Platform, Panopto Lecture Capture and Media Library), Infrastructure (Jira Service Management Jira Service Management Web), and Communication and Collaboration (Zoom Meetings).