Planned Electrical Outage - 70 Ship Street

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted May 01, 2026 - 08:53 EDT

Monitoring

The total duration of the window will be 8:00 AM - 4:00 PM
Posted Apr 30, 2026 - 09:04 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).