Power Outage: Multiple Buildings

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 20:43 EST

Investigating

There is currently a power outage affecting multiple buildings across campus. RI Energy is communicating with OIT on this matter.
Posted Nov 04, 2025 - 19:30 EST
This incident affected: Other (Other) and Network Connectivity and Telecommunications (Connections on College Hill North of Waterman - Buildings, Connections on College Hill South of Waterman - Buildings).