Network Outage at 51 Prospect Street

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 09:08 EST

Investigating

There is a network outage at 51 Prospect Street, affecting wired, wireless networking, and VOIP . OIT is investigating the incident.
Posted Feb 18, 2026 - 00:07 EST
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).