Partial Network Outage - 222 Richmond (Medschool) 2nd floor

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Jan 03, 2026 - 11:17 EST

Investigating

We are currently investigating this issue.
Posted Jan 03, 2026 - 09:55 EST
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).