Network Connectivity Issues Across Campus
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 22:36 EDT
Investigating
We are currently investigating this issue.
Posted Sep 22, 2021 - 20:53 EDT
This incident affected: Network Connectivity and Telecommunications (Wireless network (Brown, Brown-Guest, & Eduroam)).