MyAccount unavailable

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted May 01, 2026 - 09:26 EDT

Update

We are continuing to investigate this issue.
Posted May 01, 2026 - 09:05 EDT

Investigating

MyAccount (myaccount.brown.edu) is currently unavailable.

Our team is working to identify the root cause and implement a solution.
Posted May 01, 2026 - 09:01 EDT
This incident affected: Information Security and Accounts (MyAccount - myaccount.brown.edu).