choices.edu is experiencing intermittent downtime

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 18:32 EST

Investigating

We are currently investigating this issue.
Posted Mar 04, 2025 - 15:58 EST
This incident affected: Other (Other).