Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 05:00 EDT
Scheduled
On Wednesday, April 16, 2025, between 5:00 AM and 8:00 AM, network connectivity (including wireless) will experience a brief interruption across campus while maintenance is performed.
Posted Apr 15, 2025 - 16:18 EDT
This scheduled maintenance affected: Network Connectivity and Telecommunications (Wireless network (Brown, Brown-Guest, & Eduroam), Connections on College Hill North of Waterman - Buildings, Connections on College Hill North of Waterman - Outdoor Spaces, Connections on College Hill North of Waterman - Residence Halls, Connections on College Hill South of Waterman - Buildings, Connections on College Hill South of Waterman - Outdoor Spaces, Connections on College Hill South of Waterman - Residence Halls, Connections in Athletics and Facilities Office, Connections in Jewelry District).