There was a widespread issue with a number of University phones on Friday night. OIT has been working to fix the issue which will require manual intervention.
The reset process to resolve the problem is very simple, and you can troubleshoot your phone by following the steps in our help article:
Please note that even while phones are not working, voicemail will continue to receive messages.
If you need assistance, please contact the OIT Service Center via help@brown.edu.
Posted Jun 07, 2025 - 09:51 EDT
Identified
We have identified a fix for the issue impacting a number of physical phones. Please refer to the following Knowledge Base article for detailed instructions:
We are having some problems with a small number of physical phones connecting to the phone system. Telecom has an active case with the vendor and we are working through it at this time. We hope to have this fully resolved shortly
Posted Jun 06, 2025 - 22:49 EDT
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance)).