MyBrown Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 10:02 EST

Investigating

OIT is investigating a partial outage of my.brown.edu.
Posted Mar 05, 2026 - 15:58 EST
This incident affected: Communication and Collaboration (MyBrown Web Portal).