Power Outage Affecting Multiple Buildings

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 09:47 EST

Investigating

Rhode Island Energy is experiencing a power outage.

This currently affects the following locations:
1 Davol
110 Elm
70 Ship

Rhode Island Energy reports power is to be expected to be restored around 7:30 AM.
Posted Dec 09, 2025 - 06:56 EST
This incident affected: Other (Other).