DocuSign: Degraded Performance

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 15:51 EST

Monitoring

Brown's DocuSign service has been unavailable earlier this afternoon and is now running in a degraded condition. DocuSign is reporting that the service is continuing to improve, but the service may be slow for some Brown customers today. For status, please see: https://status.docusign.com/incidents/bc6pwwkz04t0
Posted Feb 05, 2025 - 15:36 EST
This incident affected: Other (Other).