Power Outage at Butler Hospital

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 09, 2025 - 20:13 EST

Investigating

There is a power outage at Butler Hospital, affecting Wired, Wireless, and VoIP connections at this location.
Posted Nov 09, 2025 - 17:45 EST
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).