Coeus Grant Management Login Issues

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 13:51 EDT

Investigating

Coeus Grant Management is experiencing login issues. OIT is actively working towards a resolution.
Posted Jun 26, 2025 - 15:48 EDT
This incident affected: Research (Coeus Grant Management).