Huron Issue Impacting Hosted Client Sites
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 08:34 EST
Update
Huron is continuing to investigate this issue.
Posted Jan 21, 2025 - 16:20 EST
Update
Huron is continuing to investigate this issue.
Posted Jan 21, 2025 - 16:18 EST
Investigating
Huron is still currently investigating the hosting issue with all clients and will provide an update as soon as possible.
Posted Jan 21, 2025 - 13:35 EST
This incident affected: Other (Other).