Brown's Google Workspace CAPTCHA Screen

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 16:00 EDT

Investigating

Some customers are seeing an unexpected CAPTCHA screen while accessing Brown's Google Workspace from campus wireless and VPN. We are aware of the problem, and have reported it to Google.

If you encounter an extra authorization screen while accessing Google Drive or Gmail, it is OK to click through this to continue.
Posted Sep 16, 2026 - 10:28 EDT
This incident affected: Communication and Collaboration (Google Drive, Google Mail).