Degraded Network Performance: Ladd Observatory

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 16:58 EST

Investigating

We’re experiencing issues with network connectivity at Ladd Observatory. A subset of users are impacted and our team is actively working to resolve this. We will provide more details as soon as more information becomes available.
Posted Jan 08, 2026 - 13:24 EST
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).