Cognos Performance Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 08:51 EDT

Update

Cognos Analytics is still experiencing a performance degradation. OIT continues to investigate the issue.
Posted Aug 06, 2025 - 17:19 EDT

Investigating

Cognos Analytics is experiencing a performance degradation. OIT is currently investigating the issue.
Posted Aug 05, 2025 - 12:39 EDT
This incident affected: Administrative and Business (Cognos - Analytics & Reporting).