Microsoft Outage

Incident Report for Brown University

Resolved

As of 5:15pm the widespread outage seems resolved. We will monitor for further problems.
Posted Mar 01, 2025 - 17:22 EST

Investigating

Problems are being reported widely by commercial users of Microsoft online services. OIT is investigating if Brown has been impacted and will update this alert as we learn more.
Posted Mar 01, 2025 - 17:09 EST
This incident affected: Communication and Collaboration (Office365).