Smartsheet Service Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 13:20 EDT

Identified

Some sheets in the US Smartsheet instance are failing to load. This is a vendor issue, and OIT will post updates as they become available.
Posted Aug 26, 2026 - 11:17 EDT
This incident affected: Other (Other).