Cloudflare Outage Affecting Brown Services

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 09:51 EST

Monitoring

These affected services are back online. OIT is continuing to monitor this service interruption.
Posted Nov 18, 2025 - 10:19 EST

Update

We have identified serveral Brown services experiencing interruption:

GiveCampus
BrownConnect+
https://www.brownalumnimagazine.com/
https://www.mathinstitutes.org/
https://insite.browntextbook.com/

OIT continues to monitor this outage.
Posted Nov 18, 2025 - 09:26 EST

Investigating

Cloudflare is experiencing an internal service degradation. Some Brown services may be intermittently impacted. OIT is monitoring the outage.
Posted Nov 18, 2025 - 08:56 EST
This incident affected: Other (Other).