Intermittent Internet Connectivity Issues

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 08:45 EDT

Investigating

We are experiencing intermittent problems with internet connectivity to and from campus. OIT is evaluating and investigating this problem.
Posted Apr 09, 2025 - 13:21 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).