Google Scholar Service Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 09:28 EDT

Investigating

We are aware of a problem using the Google Scholar service - the service is not accessible to some customers. Google is reporting that traffic from the Brown network looks like it may be suspicious. OIT's service teams are escalating to Google to clear the alert.

If you are experiencing difficulty, a connection to the Brown VPN may resolve the issue for you.
Posted Sep 03, 2025 - 16:34 EDT
This incident affected: Other (Other).