Network Outage

Incident Report for Brown University

Resolved

Areas with network connectivity problems have now been restored to full service. If you still have trouble connecting, it should resolve if you restart your computer.
Posted Jun 02, 2025 - 09:48 EDT

Investigating

Some locations in the Brown network may have issues connecting to network resources. OIT is aware of the issue, and we are investigating the problem.
Posted Jun 02, 2025 - 09:06 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).