Workday Outage
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 16:58 EDT
Investigating
Workday is experiencing an unplanned service outage and are actively working on a resolution.
Posted Oct 01, 2024 - 13:47 EDT
This incident affected: Administrative and Business (Workday).