NorthStar Receipt Printing Disruption at Faculty Club

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 14:28 EDT

Identified

Northstar kitchen and receipt printing at the Faculty Club is currently experiencing a service disruption. We have engaged our vendor and are working with them to resolve the issue as quickly as possible.
Posted Sep 10, 2025 - 12:52 EDT
This incident affected: Other (Other).