Dining Menu Service Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 11:48 EDT

Update

OIT is currently experiencing issues with the Brown Dining Menu. OIT is working on a resolution.
Students are encouraged to not load the dining web pages at this time.
Posted Sep 18, 2025 - 09:25 EDT

Identified

OIT is currently experiencing issues with the Brown Dining Menu. OIT is working on a resolution.
Posted Sep 18, 2025 - 09:24 EDT
This incident affected: Other (Other).