Outbound calls are not connecting

Incident Report for Brown University

Resolved

Outbound calls are now functioning.
Posted May 08, 2025 - 11:32 EDT

Investigating

Outbound calls are not connecting. OIT is investigating the situation.
Posted May 08, 2025 - 09:31 EDT
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance)).