Services Sync Delays

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 14:05 EDT

Investigating

We are currently experiencing an issue with synchronization of groups within Brown's computing environment. Some customers may experience delays in receiving new access to services.
Posted Apr 16, 2026 - 11:08 EDT
This incident affected: Other (Other).