Network Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 07:43 EDT

Update

We have confirmed wireless network and telephone service for landline and softphone apps (Jabber and Webex) are widely unavailable. Wired network connections are generally functioning. OIT continues to investigate.
Posted Aug 20, 2026 - 07:16 EDT

Investigating

We’re experiencing issues with network connectivity. A subset of users are impacted and our team is actively working to resolve this. We will provide more details as soon as more information becomes available.
Posted Aug 20, 2026 - 06:54 EDT
This incident affected: Network Connectivity and Telecommunications (Jabber, Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).