Network Outage at Bio Med Center and 195 Angell St

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 09:49 EDT

Identified

OIT has identified the issue and working on a fix.
Posted Mar 08, 2026 - 07:41 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).