Intermittent Workday Login Issues

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 09:53 EDT

Investigating

We are aware of the current login issues with Workday. OIT is currently investigating this incident.
Posted Jun 24, 2025 - 10:28 EDT
This incident affected: Administrative and Business (Workday).