Network Connectivity Issues - South of Waterman Street
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 11:31 EST
Update
We are continuing to investigate this issue.
Posted Jan 23, 2025 - 10:38 EST
Investigating
We are currently investigating this issue.
Posted Jan 23, 2025 - 10:30 EST
This incident affected: Network Connectivity and Telecommunications (Wireless network (Brown, Brown-Guest, & Eduroam), Connections on College Hill South of Waterman - Buildings).