Notice: Recent CourseTools Canvas Site Request Data Discrepancies and Access

Incident Report for Brown University

Monitoring

A fix has been implemented and we are monitoring the results. Please reach out to dld@brown.edu if your course still shows "Cancelled"
Posted Jan 13, 2026 - 10:51 EST

Investigating

Some active Brown courses listed at as "Cancelled," which prevents site creation in CourseTools. Additionally, some instructors are currently unable to request their own sites directly through the standard process.

If your course is incorrectly listed as "Cancelled," contact dld@brown.edu immediately to have it corrected.
Posted Jan 12, 2026 - 14:13 EST
This incident affects: Teaching and Learning (Canvas Course Platform).