Deskpro help request system display issues

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 16:05 EST

Investigating

The Deskpro help request system is experiencing issues with images and attachments not displaying for tickets created in the last several days.

We are investigating and will provide updates as more information becomes available.
Posted Nov 05, 2025 - 09:22 EST
This incident affected: Administrative and Business (Deskpro Help Request System and IT Knowledgebase - ithelp.brown.edu).