Globus Performance Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 10:01 EDT

Investigating

We are currently experiencing an outage with Globus.

Impacted Services: Globus transfers involving Files22 Research, LRSResearch, Library endpoints, and guest collections. All data transfers are currently affected.

OIT is aware of the performance degradation and is actively working to restore full service. We will update this page and remove this notification once the issue is fully resolved.
Posted Jul 17, 2025 - 09:16 EDT
This incident affected: Research (Globus File Transfers, VAST - files22.brown.edu).