Alumni cannot access Rosetta Stone
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 13:23 EST
Investigating
Alumni cannot currently access Rosetta Stone. OIT is investigating this issue, and will provide updates as they become available.
Posted Jan 21, 2025 - 13:12 EST
This incident affected: Other (Other).