OIT Emergency Maintenance: Deskpro Help Request System

Incident Report for Brown University

Resolved

This incident has been resolved. If you are still experiencing issues with DeskPro, please contact the OIT Service Center at 401-863-4357.
Posted Apr 24, 2026 - 11:01 EDT

Investigating

OIT's Deskpro service is currently going through emergency maintenance. IT ticket services may be unstable for a short period while we work on our systems.
Posted Apr 24, 2026 - 10:15 EDT
This incident affected: Administrative and Business (Deskpro Help Request System and IT Knowledgebase - ithelp.brown.edu).