Globus and Files22 Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 13:34 EST

Investigating

We are experiencing a service outage for Globus and Files22. OIT is investigating the issue.
Posted Feb 19, 2026 - 13:23 EST
This incident affected: Research (Globus File Transfers, VAST - files22.brown.edu).