Intermittent VPN Authentication Issues

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 19:17 EDT

Investigating

We are currently experiencing intermittent VPN authentication issues. OIT is investigating this issue.
Posted Apr 14, 2026 - 18:24 EDT
This incident affected: Network Connectivity and Telecommunications (VPN - Virtual Private Network).