Brown Pre-College Online Course Email

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted May 16, 2025 - 10:30 EDT

Monitoring

The recent email regarding enrollment in a Brown Pre-College online course is legitimate and was sent from a trusted Brown University email account. However, it was distributed in error to a much broader group than intended, including individuals who are not currently enrolled or affiliated with our Pre-College programs.

This message is not phishing and is not a security incident or indicative of an identity compromise. You do not need to take any action or respond to the message.

We apologize for the confusion this may have caused, and we appreciate your diligence in verifying the message’s legitimacy.

If you have any additional questions or concerns, please reach out to precollege@brown.edu. Thank you.
Posted May 07, 2025 - 14:23 EDT
This incident affected: Other (Other).