Listserv unavailable

Incident Report for Brown University

Resolved

OIT has applied mitigating changes to Listserv to resolve the issue. Performance has returned to normal.

If you notice further issues with Listserv being inaccessible, please contact the OIT Service Center: help@brown.edu or (401) 863-4357
Posted May 01, 2026 - 18:15 EDT

Update

The Listserv email list service is degraded. Emails to lists may be delayed and logging in to the Listerv web interface may be degraded or unavailable intermittently.

OIT is investigating.
Posted May 01, 2026 - 14:44 EDT

Investigating

We are currently experiencing a service disruption with Listserv.

Our team is working to identify the scope and root cause and implement a solution.
Posted May 01, 2026 - 14:37 EDT
This incident affected: Communication and Collaboration (Listserv Email Groups).