Snowflake Outage causing Cognos Reports Errors

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:45 EDT

Investigating

Snowflake is currently experiencing an East Coast outage. The outage is causing an error in reports that use a Snowflake data source.

Reports that use the following packages are effected:
Agreements
Brown Bear Bucks Legacy
Dining Services Legacy
Grants
Housing Assignment Legacy
Human Subjects
Huron Research Suite Security
InfoEd Security
TPAC Teaching Evaluations

PLEASE NOTE: Cognos Analytics is operational—reporting is available from other data sources.
For the internal incident here's the Snowflake outage link: https://status.snowflake.com/

Snowflake Status
status.snowflake.com
Posted Oct 20, 2025 - 11:00 EDT
This incident affected: Other (Other) and Administrative and Business (Cognos - Analytics & Reporting).