VPN Experiencing Connectivity Issues

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 08:30 EDT

Investigating

OIT’s VPN service is currently experiencing a problem with its SSL certificate. OIT is aware of the outage, and is working to a solution.
Posted Sep 17, 2026 - 07:39 EDT
This incident affected: Network Connectivity and Telecommunications (VPN - Virtual Private Network).