Network Outage at Mencoff Hall
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 13:59 EDT
Investigating
There is a network outage at Mencoff Hall affecting wired and wireless networking.
OIT is investigating the incident.
Posted Sep 29, 2024 - 21:20 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).