We believe that all affected services are working as expected. directory.brown.edu is now accessible from anywhere, but requires a Brown login. If you are still experiencing any issues which may be related to this incident, please contact the OIT Service Center at (401) 863-4357, help@brown.edu, or https://ithelp.brown.edu/.
Posted Apr 08, 2026 - 12:00 EDT
Monitoring
This issue has been resolved. To remediate performance and data security issues, at this time directory.brown.edu is only accessible from campus wired and wireless networks or the Brown VPN.
Posted Apr 08, 2026 - 10:22 EDT
Investigating
Brown Services using Shibboleth Single Sign On continue to experience intermittent outages. During this time, you may experience issues logging in to Brown services. OIT is continuing to investigate.
Posted Apr 08, 2026 - 09:38 EDT
This incident affected: Information Security and Accounts (Brown Directory - directory.brown.edu, Shibboleth Single-Signon Authentication).