Partial Network Outage: 222 Richmond St., 2nd floor

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 16:32 EDT

Identified

We’re experiencing issues with network connectivity on the 2nd floor of the Warren Alpert Medical School at 222 Richmond St. A subset of users are impacted and our team is actively working to resolve this. We will provide more details as soon as more information becomes available.
Posted Apr 06, 2026 - 15:52 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).