Intermittent WiFi Issues

Incident Report for Brown University

Monitoring

A fix has been implemented and we believe the issue to be resolved.

In the event WiFi issues are ongoing, please contact the Service Center at (401) 863-4357.
Posted Dec 04, 2025 - 17:41 EST

Update

Wifi has been down since 2:05pm in many spaces on College Hill and the Jewelry District.

OIT has escalated for highest-urgency support with our vendor and are investigating further.
Posted Dec 04, 2025 - 15:33 EST

Update

We experienced a widespread outage from approximately 1:53 to 1:55 and will continue to investigate intermittent problems.
Posted Dec 04, 2025 - 14:11 EST

Investigating

OIT is investigating sporadic WiFi connectivity issues affecting multiple areas across College Hill and Jewelry District areas.

We advise the use of a mobile hotspot if available, or connecting to a wired network connection and disabling WiFi on your device where that is available.
Posted Dec 04, 2025 - 10:07 EST

Monitoring

The solution that was implemented has been effective and services should be restored. OIT will continue to monitor throughout the day.
Posted Dec 03, 2025 - 14:46 EST

Update

OIT is currently investigating a fix for the ongoing issue and has implemented a potential solution at 2:00PM. Please be aware that you may still be experiencing issues while we're monitoring network connectivity.
Posted Dec 03, 2025 - 14:31 EST

Investigating

We are currently aware of an ongoing Intermittent Network Issue regarding Brown Networks. OIT is investigating.
Posted Dec 03, 2025 - 10:33 EST
This incident affects: Network Connectivity and Telecommunications (Wireless network (Brown, Brown-Guest, & Eduroam)).